crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )


  Ответ в Qt4 + KDE3
Введите ваше имя
Подтвердите код

Введите в поле код из 6 символов, отображенных в виде изображения. Если вы не можете прочитать код с изображения, нажмите на изображение для генерации нового кода.
 

Опции сообщения
 Включить смайлы?
Иконки сообщения
(Опционально)
                                
                                
  [ Без иконки ]
 


Последние 10 сообщений [ в обратном порядке ]
Litkevich Yuriy Дата 8.12.2008, 23:40
 
Цитата(MelkorBSD @ 9.12.2008, 2:16) *
Я же не статически собираюсь линковать
а какая разница, работать-то им все равно вместе. Вообщем я все равно сомневаюсь в удачном исходе.
MelkorBSD Дата 8.12.2008, 23:16
 
Цитата(Litkevich Yuriy @ 6.12.2008, 23:08) *
Цитата(molchanoviv @ 7.12.2008, 0:48) *
в историю KDElib 3
который в свою очередь потянет Qt3, а две версии Qt я сомневаюсь, что будут нормально работать (элементарно можно пересечься с именами классов)
И с qmake видимо тоже будет проблема.

А причем тут это? Я же не статически собираюсь линковать qt4-программу с библиотекой kdelib.
Litkevich Yuriy Дата 7.12.2008, 1:51
 
Цитата(ViGOur @ 7.12.2008, 2:37) *
Ты забываешь, что в Qt 4 есть поддержка классов Qt 3.
Цитата(molchanoviv @ 7.12.2008, 2:46) *
Тока вот называются они не так как в Qt3.

Вот-вот, поддержка реализована по принципу, скармливаем утилите наши исходники она меняет названия классов на новые, дальше работаем с Qt4.

К стати, я вспомнил, тут человек на форуме, по лету с этой поддержкой Qt3 бился, в итоге решил пользовать Qt3 под виндовоз (Q...free)
molchanoviv Дата 6.12.2008, 23:46
 
Цитата(ViGOur @ 6.12.2008, 23:37) *
Цитата(Litkevich Yuriy @ 6.12.2008, 23:08) *
который в свою очередь потянет Qt3, а две версии Qt я сомневаюсь
Ты забываешь, что в Qt 4 есть поддержка классов Qt 3.


Тока вот называются они не так как в Qt3.
ViGOur Дата 6.12.2008, 23:37
 
Цитата(Litkevich Yuriy @ 6.12.2008, 23:08) *
который в свою очередь потянет Qt3, а две версии Qt я сомневаюсь
Ты забываешь, что в Qt 4 есть поддержка классов Qt 3.
Litkevich Yuriy Дата 6.12.2008, 23:08
 
Цитата(molchanoviv @ 7.12.2008, 0:48) *
в историю KDElib 3
который в свою очередь потянет Qt3, а две версии Qt я сомневаюсь, что будут нормально работать (элементарно можно пересечься с именами классов)
И с qmake видимо тоже будет проблема.
molchanoviv Дата 6.12.2008, 21:48
  Почему? Просто в зависимостях кроме qt4 буде еще и уходящий в историю KDElib 3.
Litkevich Yuriy Дата 6.12.2008, 17:49
 
Цитата(MelkorBSD @ 6.12.2008, 20:37) *
Возможно ли использование в программе на Qt4 классов KDE3?
сомневаюсь.
MelkorBSD Дата 6.12.2008, 17:37
  Возможно ли использование в программе на Qt4 классов KDE3?
Просмотр темы полностью (откроется в новом окне)
RSS Текстовая версия Сейчас: 26.11.2022, 21:33