crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Несоответствие версий API
Al_dr
  опции профиля:
сообщение 28.3.2011, 21:14
Сообщение #1


Новичок


Группа: Новичок
Сообщений: 5
Регистрация: 19.3.2011
Пользователь №: 2523

Спасибо сказали: 0 раз(а)




Репутация:   0  


OC SLED11
Python 2.6
установил: Qt 4.7.0
sip 4.12.1
PyQt 4.8.3
если набрать в интерпретаторе
>>> import qt

Traceback (most recent call last):

File "<stdin>", line 1, in <module>

RuntimeError: the sip module implements API v8.0 to v8.1 but the qt module requires API v3.8

>>> import sys

>>> from PyQt4 import QtGui

Traceback (most recent call last):

File "<stdin>", line 1, in <module>

RuntimeError: the sip module implements API v8.0 to v8.1 but the PyQt4.QtGui module requires API v6.0

>>>
как решить проблему?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 26.5.2020, 9:46