crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> EP93xx: driver not found
Nenaika
  опции профиля:
сообщение 19.8.2009, 12:11
Сообщение #1


Новичок


Группа: Новичок
Сообщений: 3
Регистрация: 19.8.2009
Пользователь №: 1008

Спасибо сказали: 0 раз(а)




Репутация:   0  


Добрый день. Начинаю программировать с использованием библиотеки QtEmbedded, собранной для для ARM. Столкнулся с проблемой приложения при запуске выдают ошибку - EP93xx: driver not found. Библиотека версии 4.4.0 (пробовал и 4.5.0 - тоже самое) и компилятор arm-linux-gcc-4.1.1-920t. Может кто сталкивался?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
AD
  опции профиля:
сообщение 19.8.2009, 12:18
Сообщение #2


Профессионал
*****

Группа: Участник
Сообщений: 2003
Регистрация: 4.2.2008
Из: S-Petersburg
Пользователь №: 84

Спасибо сказали: 70 раз(а)




Репутация:   17  


Цитата(Nenaika @ 19.8.2009, 13:11) *
Столкнулся с проблемой приложения при запуске выдают ошибку - EP93xx: driver not found. Библиотека версии 4.4.0 (пробовал и 4.5.0 - тоже самое) и компилятор arm-linux-gcc-4.1.1-920t. Может кто сталкивался?

Вполне возможно, что данная возможность не предусмотрена для Qt Embedded или же Вы неправильно используете плагины. У Вас есть работа с БД или же с какими-то особенными форматами изображений или еще что-то? Вообще объясните немного подробнее, что конкретно Вы используете из библиотеки?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Nenaika
  опции профиля:
сообщение 19.8.2009, 13:56
Сообщение #3


Новичок


Группа: Новичок
Сообщений: 3
Регистрация: 19.8.2009
Пользователь №: 1008

Спасибо сказали: 0 раз(а)




Репутация:   0  


Цитата(AD @ 19.8.2009, 12:18) *
Цитата(Nenaika @ 19.8.2009, 13:11) *
Столкнулся с проблемой приложения при запуске выдают ошибку - EP93xx: driver not found. Библиотека версии 4.4.0 (пробовал и 4.5.0 - тоже самое) и компилятор arm-linux-gcc-4.1.1-920t. Может кто сталкивался?

Вполне возможно, что данная возможность не предусмотрена для Qt Embedded или же Вы неправильно используете плагины. У Вас есть работа с БД или же с какими-то особенными форматами изображений или еще что-то? Вообще объясните немного подробнее, что конкретно Вы используете из библиотеки?

Спасибо за внимание!
С БД пока работы нет, но в будещем понадобиться, необходима работа с PNG-изображениями, может еще и jpeg - использовать думаю внутренние библиотеки QT для работы с изображениями... Но не в этом дело - не запускается даже "Hello, world". На форуме производителя железа добрый человек посоветовал следущее: "Потому что QT 4 не знает о EP93xx, нужно использовать "обычный" linuxfb драйвер для видео." Т.е. как я понимаю при сборке библиотеки необходимо указывать использование этого драйвера или же изменять настройки Linux на ARM-устройстве? Если, что не так - то я еще учусь...
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Litkevich Yuriy
  опции профиля:
сообщение 19.8.2009, 14:40
Сообщение #4


разработчик РЭА
*******

Группа: Сомодератор
Сообщений: 9666
Регистрация: 9.1.2008
Из: Тюмень
Пользователь №: 64

Спасибо сказали: 807 раз(а)




Репутация:   94  


Nenaika, не цитируй целыми сообщениями, справка по кнопкам форума тут
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Nenaika
  опции профиля:
сообщение 19.8.2009, 14:53
Сообщение #5


Новичок


Группа: Новичок
Сообщений: 3
Регистрация: 19.8.2009
Пользователь №: 1008

Спасибо сказали: 0 раз(а)




Репутация:   0  


Спасибо, учту.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 24.1.2021, 0:11