crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

2 страниц V   1 2 >  
Ответить в данную темуНачать новую тему
> MinGW
edwardoid
  опции профиля:
сообщение 2.8.2008, 13:31
Сообщение #1


Участник
**

Группа: Участник
Сообщений: 171
Регистрация: 1.5.2008
Из: Ереван, Армения
Пользователь №: 164

Спасибо сказали: 0 раз(а)




Репутация:   0  


Если попытаться поискать в сети этот компилятор, то можно найти кучу пакетов или автоматичреский инсталятор, который все равно спрашивает какой пакет выбрать какой - нет. Когда ставишь QT, он спрашивает скачать компилятор, если нажимаещь, то он находит и качает exe-шник, уже содержащий все, что нужно для QT. не мог ли кто выложить ссылку именно на этот инсталятор? Очень надо, интернета нет на компе, где надо поставить QT, а тут у меня система глючит...
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Novak
  опции профиля:
сообщение 2.8.2008, 13:57
Сообщение #2


Активный участник
***

Группа: Участник
Сообщений: 319
Регистрация: 15.3.2008
Из: Замкадыш
Пользователь №: 121

Спасибо сказали: 28 раз(а)




Репутация:   6  


Насколько я помню при установке можно выбрать опцию просто сохранить на компьютере скачаныные файлы. Потом их можно перенести на другой комп и установить все, что нужно.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Litkevich Yuriy
  опции профиля:
сообщение 2.8.2008, 14:19
Сообщение #3


разработчик РЭА
*******

Группа: Сомодератор
Сообщений: 9666
Регистрация: 9.1.2008
Из: Тюмень
Пользователь №: 64

Спасибо сказали: 807 раз(а)




Репутация:   94  


edwardoid, качай от сюда MinGW-5.1.4.exe
это только сетевой установщик, запустиш его, он сольет то что нужно с инета, как сказал Novak, надо выбрать режим загрузки, а не установки. Он все файлы в свой каталог сольет, потом возьмешь это добро и унисешь на другую машину. На ней его запустишь он увидит все файлы и ничего качать не будет, а придложет установить.

Но, надо иметь в виду, чтобы утебя ось одна и таже была на обоих машинах.

P.S. Компиллер устанавливать не обязательно. Ты можешь просто скопировать каталог с установленным компиллером с одной машины на другую. Забей в переменную окружения PATH путь к каталогу bin компилятора (например, C:\MinGW32\bin) и все будет работать.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
edwardoid
  опции профиля:
сообщение 2.8.2008, 14:30
Сообщение #4


Участник
**

Группа: Участник
Сообщений: 171
Регистрация: 1.5.2008
Из: Ереван, Армения
Пользователь №: 164

Спасибо сказали: 0 раз(а)




Репутация:   0  


а какие пакеты выбирать?

Сообщение отредактировал edwardoid - 2.8.2008, 14:35
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Litkevich Yuriy
  опции профиля:
сообщение 2.8.2008, 15:32
Сообщение #5


разработчик РЭА
*******

Группа: Сомодератор
Сообщений: 9666
Регистрация: 9.1.2008
Из: Тюмень
Пользователь №: 64

Спасибо сказали: 807 раз(а)




Репутация:   94  


ну фортран наверно тебе не нужен, что там еще я не помню, перечисли
--
у меня такие лежат в каталоге:
binutils-2.17.50-20060824-1.tar.gz
gcc-core-3.4.5-20060117-1.tar.gz
gcc-g++-3.4.5-20060117-1.tar.gz
mingw32-make-3.81-2.tar.gz
mingw-runtime-3.14.tar.gz
w32api-3.11.tar.gz
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
edwardoid
  опции профиля:
сообщение 2.8.2008, 15:42
Сообщение #6


Участник
**

Группа: Участник
Сообщений: 171
Регистрация: 1.5.2008
Из: Ереван, Армения
Пользователь №: 164

Спасибо сказали: 0 раз(а)




Репутация:   0  


ок) спс.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
trdm
  опции профиля:
сообщение 2.9.2008, 12:16
Сообщение #7


Дмитрий Трошин
****

Группа: Участник
Сообщений: 575
Регистрация: 12.1.2008
Пользователь №: 68

Спасибо сказали: 21 раз(а)




Репутация:   6  


Вообще с gcc и gdb под windows полная лажа :((((((((((
в винде:
gcc --version
gcc (GCC) 3.4.2 (mingw-special)
gdb --version
GNU gdb 6.3
шас в линь схожу версии посмотрю.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
trdmLi
  опции профиля:
сообщение 2.9.2008, 12:28
Сообщение #8


Новичок


Группа: Новичок
Сообщений: 1
Регистрация: 2.9.2008
Пользователь №: 281

Спасибо сказали: 0 раз(а)




Репутация:   0  


gcc --version
gcc (GCC) 4.2.1 (SUSE Linux)
gdb --version
GNU gdb 6.6.50.20070726-cvs
Короче в лине gcc намного новее. А на винде конкретно отстает.
Есть выход?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
trdm
  опции профиля:
сообщение 2.9.2008, 12:32
Сообщение #9


Дмитрий Трошин
****

Группа: Участник
Сообщений: 575
Регистрация: 12.1.2008
Пользователь №: 68

Спасибо сказали: 21 раз(а)




Репутация:   6  


Хоть только в лине и работай, а в винде на интел переходи...
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Litkevich Yuriy
  опции профиля:
сообщение 2.9.2008, 12:36
Сообщение #10


разработчик РЭА
*******

Группа: Сомодератор
Сообщений: 9666
Регистрация: 9.1.2008
Из: Тюмень
Пользователь №: 64

Спасибо сказали: 807 раз(а)




Репутация:   94  


[offtop]
trdmLi, а за каким лешим ты регистрируешся под разным ником? (твоя фамилия ведь не меняется от того работаешь ты в виндовозе или линухе)
[/offtop]

На SourceForge есть 4-ая версия, но она числится как Альфа, тык
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

2 страниц V   1 2 >
Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 14.4.2021, 20:44