Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Установка qtsdk в МСВС
Форум на CrossPlatform.RU > Библиотеки > Qt > Qt инструментарий
zelibobrik
мой начальник сказал мне сделать программу которая будет работать в windows , linux ( в частности в МСВС 3.0 ФЛИР.80001-12). Он же сказал что писать надо в qt. Qt в составе МСВС версии 3.3.3 мне чет как-то сильно не понравилась. В интернете я скачал QtSdk-offline-win-x86-v1_2_1.exe и установил на комп с windows7 x64. Программку напиисал,скомпилировал, получил exe'шник ,скинул к нему библеотеки на которые ругался и он нормально запустился. Потом возник вопрос как запустить программу под МСВС. Сначала попробовал просто скопировать проект из windows в МСВС и скомпилировать его. вылезли ошибки. оно впрочем и понятно. Потом решил поискать в интернете можно ли как то из под винды получить исполняемый файл программы для linux, но нашел лишь как под Linux'ом делать exe'шники. А потом решил поставить свежию версию qt в мсвс и началось...:

скачал QtSdk-offline-linux-x86-v1.2.1.run но при запуске выдало ошибку об отсутсвии библиотеки libstdc++.s0.6

потом скачал:
скачал qt-everywhere-opensourse-src-4.8.1 при запуске выдает : qt-everywhere-opensourse-src-4.8.1.txt

потом скачал:
qt-creator-linux-x86-opensource-2.4.1.bin при запуске нормально установилось, но при запуске ярлыка на рабочем столе ничего не происходит

потом решил вернуться к qtsdk и решил найти как установить библиотеку libstdc++.s0.6 . Скачал gcc-4.7.0.tar.gz , разархивировал, попробовал установить, но вылезла просьба установить еще gmp, mpc and/or mprf.

скачал gmp-4.3.2 , mpc-0.8.1 , mprf-2.4.2
установил gmp без проблем :
- ./configure
- make
- make check
- make install
все тесты вроде Ok

установка mpc : mpc.txt
установка mprf: mprf.txt

Несмотря на ошибки при тестах решил снова поставить gcc-4.7.0 , но нефига не вышло : gcc.txt


В итоге я не знаю что делать дальше. И есть 2 вопроса : можно ли все же из под windows создать исполняемый файл для МСВС? и что я сделал не так для установки qtsdk в мсвс?
sobre
актуально!
Гость
Скачай сорцы, и собери теми тулсетами которые, есть под mcbc, под твою версию стабильно компилится qt до 4,6,1 включительно(это было не однократно проверенно).
Если нужен более новый Qt, то возможно тулсет придется собирать тоже в ручную.
Но в 1 очередь, лучше узнай какая версия Qt сертифицирована для вашей организации, и, по идее, у вас в организации должна быть бинарная сборка Qt под MCBC необходимой версии.
trin
чтобы не скидывать библиотеки под винду Qt надо пересобрать как вариант

по поводу МСВС , скорее всего разные версии Qt под виндой и там

сбрасываем проект в папочку, заходим туда и в консоли пишем:

Раскрывающийся текст

gccv4
qmake4
make


после этого по идее должно собраться и даже запускаться, если версии не сильно отличались

p.s. под мсвс должен Qt Creator версии 1.2.1 работать
zelibobrik
Получилось собрать qt 4.5.3 и qtcreator 1.2.1
проект скомпилировался и запустился нормально :) взял рекомендации по установке отсюда
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Форум IP.Board © 2001-2018 IPS, Inc.