Помощь - Поиск - Пользователи - Календарь
Полная версия этой страницы: Баги в форуме
Форум на CrossPlatform.RU > Административный > Обратная связь
Страницы: 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13, 14
Гость_razrfalcon_*
Снова не могу создавать тему/сообщения...
Litkevich Yuriy
сегодня у меня форум сильно тормозит.
ViGOur
Все поправил. Забыл в прошлый раз сделать на постоянной основе.
Больше не должно вроде слетать...
RazrFalcon
Спасибо.
ViGOur
Не зачто, только что проверил. Все нормально должно быть. Слетало во время перезагрузки... :)
igor_bogomolov
в RSS не приходят сообщения из раздела "Интерпретируемые языки"
ViGOur
Поправил
Алексей1153
что-то непонятное с кнопкой цитаты: цитируется только сам текст, но не заключается в тег цитаты с именем автора (так вроде было же раньше? )

сижу в Google Chrome
Litkevich Yuriy
Цитата(Алексей1153 @ 5.6.2011, 20:26) *
сижу в Google Chrome
в Опере 9.27 всё путём (кнопка "++Цитата")
Алексей1153
значит, гугль подкачал (
решил попробовать - а он мне шота вообще не нравится. Такой глючный, виснет часто
alex977
Цитата(Litkevich Yuriy @ 5.6.2011, 17:29) *
Цитата(Алексей1153 @ 5.6.2011, 20:26) *
сижу в Google Chrome
в Опере 9.27 всё путём (кнопка "++Цитата")

Аналогично. FireFox 5.0.
ViGOur
Некоторые проблемы наблюдаются только с Webkit подобными браузерами.
Даже и не знаю грешить на их плохую реализацию ява скрипта или как! :)
Litkevich Yuriy
К стати, Эдик, а как у нас дела с возможностью анонимов и новичков писать в личку админам/модераторам?
DOGG
Почему-то не могу изменить ни какую информацию о себе - ни личные данные, ни подпись, ни аватар? говорит на все - "Вам запрещено использование этой функции форума"... плохая карма?:)
BRE
Подожди. Думаю после 20 сообщения у тебя ряд функций станет доступно.
ViGOur
Не совсем так, просто пока вам не исполнится 20 полезных сообщений, эта функция не откроется.
Хотя если очень нужно, я могу её открыть... :)
DOGG
Спасибо за информацию, просто не нашел в правилах где об этом написано!:) пересмотрю еще разок!
ViGOur
Это пока не написано... :)
Просто мы таким не хитрым способом защищаемся от спамеров.

Перевел в другую группу, пробуй сейчас...
DOGG
Спасибо! Теперь все работает! :)
Tonal
Страница поиска: http://crossplatform.ru/search.php отображается «кракозябрами».
Похоже дело в том, что в заголовке стоит кодировка windows-1251 а весь текст в utf-8
Admin
поправил
Iron Bug
У меня сдохло цитирование. После смены венды на 7 64 и нового эксплорера 9. Вроде жабаскрипт включен, на прочих сайтах он нормально работает. А тут при нажатии кнопки "++Цитата" он тупо копирует строку без всякого обрамления (только текст).
При нажатии "Ответить" текст цитируется нормально.
ViGOur
Посмотрю как поправить, у меня та же проблема! :(
Iron Bug
Цитата(ViGOur @ 17.11.2011, 18:01) *
Посмотрю как поправить

http://tcpc.ipbhost.com/index.php?/topic/2...updating-board/
посмотри, вот тут пишут, что это зависит от библиотеки Prototype. можно ли обновить эту библиотеку? это должно решить проблему.
ViGOur
У меня её нет, там скорее всего просто другой мод используется...


сейчас как, попробуй?
у меня просто дома линукс, тут всё работает...
Iron Bug
ничего не изменилось. тык на "++Цитата" даёт только копирование выделенного текста, без генерации тега цитирования.
Алексей1153
в гуглохроме на винде XP SP3 - такое же поведение
Iron Bug
ура! у меня цитирование заработало! :) правда, я тут утром ковыряла какие-то настройки эксплорера, но не думаю, что из-за этого.
под вендой 7 64 с эксплорером 9 цитирование работает.
Алексей1153
в ИЕ то работало и работает, да. А в хроме - неа (
ViGOur
Кажется поправил. По крайней мере под Google Chrome работает IE как я уже говорил дома нет, проверить не могу. :(

Проверяйте!

Перед тем как будете проверять не забудьте обновить кэш, а то яваскрипт он такой, может там сидеть до поры до времени! :)
ViGOur
Цитата(Iron Bug @ 18.11.2011, 15:01) *
ура! у меня цитирование заработало! :) правда, я тут утром ковыряла какие-то настройки эксплорера,
может из-за того, что ты ковыряла, а может из-за того, что я вчера! :)
Iron Bug
Цитата(ViGOur @ 19.11.2011, 0:03) *
может из-за того, что ты ковыряла, а может из-за того, что я вчера!

проверить смогу только в понедельник. дома я венду не держу. я точно помню, что я конкретно ковыряла, так что могу вернуть всё взад :)
но скорее всего, это просто не сразу обновился кэш на моём компе или на проксе и скрипты обновились не сразу.
Алексей1153
у меня без изменений (в гуглохроме)
zloiia
В гуглохроме не работают кнопки редактора при создании сообщения. Ни жирным не выделить, ни быстро тэги расставить. Не критично конечно, но неприятно (((

Поправка. Вообще JavaScript тут не работает. Нигде. В других местах только в лет, а тут нет
RazrFalcon
Цитата(zloiia @ 28.12.2011, 1:21) *
В гуглохроме не работают кнопки редактора при создании сообщения. Ни жирным не выделить, ни быстро тэги расставить. Не критично конечно, но неприятно (((

Поправка. Вообще JavaScript тут не работает. Нигде. В других местах только в лет, а тут нет

+1
Алексей1153
а быстрое редактирование отменили ?
Iron Bug
кстати, у меня дома на 8-й мозилле под линём не работает цитирование. на наботе на эксплорере 9 работает.
ViGOur
Я знаю об этой проблеме, вот только не знаю как её решить... :(
igor_bogomolov
Цитата(zloiia @ 28.12.2011, 2:21) *
В гуглохроме не работают кнопки редактора при создании сообщения. Ни жирным не выделить, ни быстро тэги расставить.
Не знаю зависит ли от браузера, просто я заметил, что не работают некоторые стили форума. Если конкретно, работают только стили "SEO", "Light", "Cafe", "Серый". Во всех остальных кнопки редактирования не работают.

Firefox 8.0
Iron Bug
кстати, вчера обнаружила, что вставка изображения и прочие кнопени редактора в Мозилле Firefox 8.0 тоже не работают. просто никакого окна не открывается, ничего не происходит. жабаскрипт вроде не запрещён. может, и вправду зависит от стиля. я не проверяла.
Багира
Вопрос - дело именно в браузере? У кого и в каких браузерах кнопки _работают_?
Iron Bug
у меня в эксплорере 9 вроде работали. насчёт вставки картинок я не проверяла, но цитирование работало.
дома в Firefox 8.0.1 кнопки не работают вообще никакие. жабаскрипт включен, на других сайтах он работает.

P.S. может, имеет значение ещё и битность? у меня 64-битный Firefox.
BRE
Цитата(Iron Bug @ 4.1.2012, 16:27) *
дома в Firefox 8.0.1 кнопки не работают вообще никакие. жабаскрипт включен, на других сайтах он работает.

У меня Firefox 9.0.1 64-битный - все вроде работает.
Iron Bug
поставила Firefox 9.0.1. реакции не было. решила поковырять темы. и, блин, точно: этот глюк зависит от темы оформления сайта! поставила тему SEO вместо "Зима" - заработали смайлы, кнопки WYSIWIG редактора. но цитирование всё равно не работает: "цитата+" перекидывает на начало страницы почему-то, но не добавляет выделенный текст в окно ответа, а "цитата++" ничего не делает вообще.

дурдом какой-то невнятный.
Litkevich Yuriy
Цитата(Iron Bug @ 4.1.2012, 13:35) *
кстати, вчера обнаружила, что вставка изображения и прочие кнопени редактора в Мозилле Firefox 8.0
аналогично в Опере, ещё не пробовал кэш браузера полностью чистить (помнится после каких-то работ на форуме это помогало).
Iron Bug
Цитата(Litkevich Yuriy @ 5.1.2012, 5:14) *
ещё не пробовал кэш браузера полностью чистить (помнится после каких-то работ на форуме это помогало).

это первое, что я делаю при глюках. я ж вебом занималась одно время, все эти фишки знаю. но это не помогло. может, имеет смысл на сервере кэш почистить, если он там есть. скрипты могли закэшироваться, например. во всяком случае, это как-то связано с темами оформления и жабаскриптом.
Багира
Дело ясное, что дело темное. :D
Наверняка какая-нибудь мелочь при установке тегов... будем рыть.
Iron Bug
я сейчас поковырялась в отладчике и поняла, в чём проблема с цитированием:

заюзаны функция copyQ и pasteQ - это эксплорерские функции, реализованные через вижуал-васик. естественно, под мозиллой, оперой и прочими это не работает.
я нашла готовое решение этой задачи:
http://forum.ru-board.com/topic.cgi?forum=13&topic=0864

там в общем понятно написано, если что - могу пояснить более детально. суть в том, что создаётся эмуляция этих функций (код там есть) для случаев, когда васик отсутствует.

P.S. ща попробую понять, что не так со стилями.
Iron Bug
нашла и второй баг(с неработающими кнопками редактора). по крайней мере, в теме "Зима".
там, где прописываются скрипты (заголовок?) - тупо опечатки или удалены куски кода (поэтому не подцепляется window.ipsclass)
в мозилле грузится такой код:
<script type="text/javascript" src='http://www.forum.crossplatform.ru/jscripts/ips_menu.js'></script>

<script type="text/javascript" src='http://www.forum.crossplatform.ru/style_images/winter/folder_js_skin/ips_menu_html.js'>
<script type="text/javascript" src='http://www.forum.crossplatform.ru/cache/lang_cache/ru/lang_javascript.js'></sc
<script type="text/javascript">


должно быть что-то типа
<script type="text/javascript" src='http://www.forum.crossplatform.ru/jscripts/ips_menu.js'></script>

<script type="text/javascript" src='http://www.forum.crossplatform.ru/style_images/winter/folder_js_skin/ips_menu_html.js'></script>
<script type="text/javascript" src='http://www.forum.crossplatform.ru/cache/lang_cache/ru/lang_javascript.js'></script>
<script type="text/javascript">


возможно, пропущены какие-то инклюды ещё. сравнивать можно с темой SEO - она под мозиллой работает.
Багира
Цитата(Iron Bug @ 7.1.2012, 3:26) *
заюзаны функция copyQ и pasteQ - это эксплорерские функции, реализованные через вижуал-васик.
Нет. Дело НЕ в скрипте, поскольку работает в некоторых стилях. Думаю, где-то что-то сместил админ именно в стилях. А что - надо смотреть модуль.
И функции яваскриптовые... просто... надо было как-то назвать. :D

Добавлено позднее:
А, вот следующее сообщение - как раз то, что надо.

Добавлено:
Вернула ссылки скриптам - теперь все работает.
Для просмотра полной версии этой страницы, пожалуйста, пройдите по ссылке.
Форум IP.Board © 2001-2022 IPS, Inc.