crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

> Проблема с QIBASE (firebird+ubuntu)
tp4
  опции профиля:
сообщение 8.8.2011, 20:02
Сообщение #1


Студент
*

Группа: Участник
Сообщений: 32
Регистрация: 1.10.2009
Пользователь №: 1128

Спасибо сказали: 1 раз(а)




Репутация:   0  


Здравствуйте, господа!

Пытался скомпилить драйвер QIBASE для работы с Firebird в Ubuntu и протестить его работу с использованием sqlbrowser'а из демок.
Вытоге при нажатии на кнопке "OK" sqlbrowser'а, программа аварийно завершается с сообщением:
Цитата
/opt/qt-everywhere-opensource-src-4.7.3/demos/sqlbrowser-build-desktop/sqlbrowser: symbol lookup error:
/usr/lib/qt4/plugins/sqldrivers/libqsqlibase.so: undefined symbol: isc_attach_database


Делал следующее:
1. Установил FirebirdCS-2.5.0 в /opt/firebird.
2. Распаковал исходники qt в /opt/qt4. (На момент начала всех действий qt4 была установлена из бинарников)
3. Компиляция драйвера:
Цитата
cd /opt/qt/src/plugins/sqldrivers/ibase
qmake -o Makefile "INCLUDEPATH+=/opt/firebird/include" "LIBS+=-L/opt/firebird/lib/libfbclient.so" ibase.pro

4. Положил собранную libqsqlibase.so в /usr/lib/qt4/plugins/sqldrivers
5. Заполняю все поля sqlbrowser'а, нажимаю OK и программа аварийно завершается с вышеуказанным сообщением.

СУБД и база в порядке - успешно конектился с помощью isql и исполнял запросы.

Помогите, пожалуйста, разобраться в проблеме. Буду очень благодарен. Спасибо.

Ubuntu 10.10, Qt4, firebird 2.5.0.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
 
Начать новую тему
Ответов (1 - 8)
mishabard
  опции профиля:
сообщение 9.8.2011, 11:28
Сообщение #2


Студент
*

Группа: Участник
Сообщений: 31
Регистрация: 13.6.2011
Из: Киев
Пользователь №: 2741

Спасибо сказали: 0 раз(а)




Репутация:   0  


Было примерно тоже самое, правда у меня еще и c isql было проблемно подключиться. В итого установил firebird 2.1. Если у тебя получится - напиши подробно как ты 2.5 поднял.
Причина редактирования: не нужно цитировать целыми сообщениями
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
tp4
  опции профиля:
сообщение 9.8.2011, 11:43
Сообщение #3


Студент
*

Группа: Участник
Сообщений: 32
Регистрация: 1.10.2009
Пользователь №: 1128

Спасибо сказали: 1 раз(а)




Репутация:   0  


Цитата(mishabard @ 9.8.2011, 12:28) *
Было примерно тоже самое, правда у меня еще и c isql было проблемно подключиться. В итого установил firebird 2.1. Если у тебя получится - напиши подробно как ты 2.5 поднял.


2.5. устанавливал очень просто:
1. скачал FirebirdCS-2.5.0.
2. распаковал
3. запустил install.sh
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Litkevich Yuriy
  опции профиля:
сообщение 9.8.2011, 16:44
Сообщение #4


разработчик РЭА
*******

Группа: Сомодератор
Сообщений: 9669
Регистрация: 9.1.2008
Из: Тюмень
Пользователь №: 64

Спасибо сказали: 807 раз(а)




Репутация:   94  


а Qt какой версии?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
tp4
  опции профиля:
сообщение 9.8.2011, 17:26
Сообщение #5


Студент
*

Группа: Участник
Сообщений: 32
Регистрация: 1.10.2009
Пользователь №: 1128

Спасибо сказали: 1 раз(а)




Репутация:   0  


Цитата(Litkevich Yuriy @ 9.8.2011, 17:44) *
а Qt какой версии?

4.7.0.
А драйвер собираю из исходников 4.7.3. На sql.ru подсказывают, что в несоответствии этих версий может быть проблема. Попробую собрать библиотеку полностью из исходников и проделать заново процедуры по компиляции драйвера.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Litkevich Yuriy
  опции профиля:
сообщение 9.8.2011, 19:16
Сообщение #6


разработчик РЭА
*******

Группа: Сомодератор
Сообщений: 9669
Регистрация: 9.1.2008
Из: Тюмень
Пользователь №: 64

Спасибо сказали: 807 раз(а)




Репутация:   94  


Цитата(tp4 @ 9.8.2011, 20:26) *
4.7.0.
А драйвер собираю из исходников 4.7.3. На sql.ru подсказывают, что в несоответствии этих версий может быть проблема.
не может. В патч-версии не вносят изменения, только исправления. Исправления в модуле SQL я что-то не припомню даже между 4.6 / 4.7
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
tp4
  опции профиля:
сообщение 10.8.2011, 10:49
Сообщение #7


Студент
*

Группа: Участник
Сообщений: 32
Регистрация: 1.10.2009
Пользователь №: 1128

Спасибо сказали: 1 раз(а)




Репутация:   0  


Цитата(Litkevich Yuriy @ 9.8.2011, 20:16) *
Цитата(tp4 @ 9.8.2011, 20:26) *
4.7.0.
А драйвер собираю из исходников 4.7.3. На sql.ru подсказывают, что в несоответствии этих версий может быть проблема.
не может. В патч-версии не вносят изменения, только исправления. Исправления в модуле SQL я что-то не припомню даже между 4.6 / 4.7


Все-таки компиляция с 4.7.3 решила проблему.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
mishabard
  опции профиля:
сообщение 10.8.2011, 11:47
Сообщение #8


Студент
*

Группа: Участник
Сообщений: 31
Регистрация: 13.6.2011
Из: Киев
Пользователь №: 2741

Спасибо сказали: 0 раз(а)




Репутация:   0  


Цитата(tp4 @ 10.8.2011, 10:49) *
Цитата(Litkevich Yuriy @ 9.8.2011, 20:16) *
Цитата(tp4 @ 9.8.2011, 20:26) *
4.7.0.
А драйвер собираю из исходников 4.7.3. На sql.ru подсказывают, что в несоответствии этих версий может быть проблема.
не может. В патч-версии не вносят изменения, только исправления. Исправления в модуле SQL я что-то не припомню даже между 4.6 / 4.7


Все-таки компиляция с 4.7.3 решила проблему.

Если решили проблему, то можете подробно описать действия. как запустить firebird 2.5 в Qt. Какие обновления откуда скачать. Если можно по пунктам. Можети другим пригодится. Спасибо!
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
tp4
  опции профиля:
сообщение 10.8.2011, 13:12
Сообщение #9


Студент
*

Группа: Участник
Сообщений: 32
Регистрация: 1.10.2009
Пользователь №: 1128

Спасибо сказали: 1 раз(а)




Репутация:   0  


Цитата(mishabard @ 10.8.2011, 12:47) *
Если решили проблему, то можете подробно описать действия. как запустить firebird 2.5 в Qt. Какие обновления откуда скачать. Если можно по пунктам. Можети другим пригодится. Спасибо!


Да, конечно. Сейчас попробую. Только у меня на данном этапе не стояло задачи корректно поставить firibird в Linux. Цель была установить абы-как, лишь бы можно было скомпилить драйвер и проверить корректность работы программы в иксах.

Итак, для установки и запуска Firebird2.5. делал следующее:

1. Со странички http://www.firebirdsql.org/en/firebird-2-5/ скачал FirebirdCS-2.5.0.26074-0.i686.tar.gz из раздела Linux x86.
2. Распаковал в /opt/
3. cd /opt/FirebirdCS-2.5.0.26074-0.i686
4. sudo ./install.sh - установка по умолчанию произвелась в /opt/firebird
5. apt-get istall firebird2.5-dev
6. sudo /opt/firebird/bin/fb_init_server
7. sudo /opt/firebird/bin/isql
8. CONNECT "путь к бд"
9. user 'SYSDBA' password 'masterkey'
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 20.7.2024, 18:32