crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> cmake и несколько верси Qt, как указать какую версию использовать?
igor_bogomolov
  опции профиля:
сообщение 16.12.2010, 11:24
Сообщение #1


Профессионал
*****

Группа: Сомодератор
Сообщений: 1215
Регистрация: 22.3.2009
Из: Саратов
Пользователь №: 630

Спасибо сказали: 235 раз(а)




Репутация:   29  


Платформа Linux.

По мимо системной, имею еще две версии Qt, установленных по следующим путям
/usr/local/Trolltech/Qt-4.7.1
/usr/local/Trolltech/Qt-4.7.2

Как указать cmake какую версию Qt нужно использовать для сборки?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
panter_dsd
  опции профиля:
сообщение 16.12.2010, 12:17
Сообщение #2


Жаждущий знаний
***

Группа: Участник
Сообщений: 254
Регистрация: 1.1.2009
Из: Санкт-Петербург
Пользователь №: 474

Спасибо сказали: 32 раз(а)




Репутация:   3  


export PATH=/usr/local/Trolltech/Qt-4.7.1:$PATH
mkdir build_unix
cd build_unix
cmake ..
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 7.7.2020, 17:49