crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

> Помогите новичку.
xleksx
  опции профиля:
сообщение 24.9.2010, 21:14
Сообщение #1


Новичок


Группа: Новичок
Сообщений: 9
Регистрация: 24.9.2010
Пользователь №: 2066

Спасибо сказали: 0 раз(а)




Репутация:   0  


Всем привет, только начал Qt учить, заранее извиняюсь за глупый вопрос...
Проблема такая:
Пишу прогу, которая подгружает картинку и показывает её с помощью QLabel, ну или просто заливаю виджет картинкой...
Помещаю картинку в папку теневой сборки (desktop) компилю и запуская из под Qt Creator'а всё нормально, картинку видно.
Но вот когда запускаю exe'шник (Релиз) картинки как-будто нету (картунку ложу рядом с exe'шником)... Если писать полный путь ("C://...") то всё нормально... в С++ вроде просто помещаешь картинку рядом с exe'шником и всё нормально, а тут не получается, помогите кто может =)
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
 
Начать новую тему
Ответов
kwisp
  опции профиля:
сообщение 25.9.2010, 13:23
Сообщение #2


астарожна ынтжинэр
*****

Группа: Участник
Сообщений: 1404
Регистрация: 26.11.2008
Из: ТаганрогРодинаЧехова
Пользователь №: 435

Спасибо сказали: 113 раз(а)




Репутация:   23  


Цитата(xleksx @ 25.9.2010, 13:29) *
И кстати даже при задании полного пути к файлу прога "видит" файл только когда запускается из под Qt Creator (релиз/отладка), а когда запуская экзешник - ничего нету...

это скорее всего кодеки картинок не видит твоя прога если запускаешь не в Creatore.
здесь на вики есть информация как исправить положение.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Сообщений в этой теме


Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 22.10.2021, 5:54