crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Вывод даты в определенном формате
++Norton++
  опции профиля:
сообщение 6.12.2009, 12:59
Сообщение #1


Студент
*

Группа: Участник
Сообщений: 98
Регистрация: 5.10.2008
Пользователь №: 380

Спасибо сказали: 0 раз(а)




Репутация:   1  


Возможно покажется совсем тупой вопрос, но все же... Я вот покапался, поискал и нигде не нашел. В стандартном виде дату и время вывести не проблема, но можно ли как-нибудь вывести в таком формате:
2009-12-03T21:58:20
Если это возможно, подскажите как?
Заранее спасибо!
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
BRE
  опции профиля:
сообщение 6.12.2009, 13:02
Сообщение #2


Профессионал
*****

Группа: Участник
Сообщений: 1112
Регистрация: 6.3.2009
Из: Ростов-на-Дону
Пользователь №: 591

Спасибо сказали: 264 раз(а)




Репутация:   44  


Цитата(++Norton++ @ 6.12.2009, 12:59) *
Если это возможно, подскажите как?

QString QDateTime::toString ( const QString & format ) const
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
SABROG
  опции профиля:
сообщение 6.12.2009, 13:05
Сообщение #3


Профессионал
*****

Группа: Участник
Сообщений: 1207
Регистрация: 8.12.2008
Из: Russia, Moscow
Пользователь №: 446

Спасибо сказали: 229 раз(а)




Репутация:   34  


QString mydate(date.toString(Qt::ISODate));
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
niXman
  опции профиля:
сообщение 6.12.2009, 13:06
Сообщение #4


Участник
**

Группа: Участник
Сообщений: 169
Регистрация: 18.6.2008
Пользователь №: 204

Спасибо сказали: 1 раз(а)




Репутация:   0  


опоздал :(

Сообщение отредактировал niXman - 6.12.2009, 13:07
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
trdm
  опции профиля:
сообщение 6.12.2009, 16:12
Сообщение #5


Дмитрий Трошин
****

Группа: Участник
Сообщений: 575
Регистрация: 12.1.2008
Пользователь №: 68

Спасибо сказали: 21 раз(а)




Репутация:   6  


Я как-то запарился с разными форматами и соорудил на 1С вот такой велосипед:
Раскрывающийся текст

//******************************************************************************
/// глДатаФормат(_дата,"№Нед (ДД.ММ.ГГГГ)")
Функция глДатаФормат( нДата, нФормат)  Экспорт
    
    ЗначВозврата = ""+нФормат;
    Если ПустоеЗначение(нДата) = 1 Тогда
        Возврат "<..>";
    КонецЕсли;
    тМесяцСтр = Формат(нДата,"Д ДДММММГГГГ");
    тМесяцСтр = глСправаОт(тМесяцСтр," ");
    тМесяцСтр = глСлеваОт(тМесяцСтр," ");
    /// заменим и время...
    вЧЧ = 0;    вММ = 0;    вСС = 0;
    вТекВремяСтр = ТекущееВремя(вЧЧ,вММ,вСС);
    вЧЧ = Лев(вТекВремяСтр,2);
    вММ = Сред(вТекВремяСтр,4,2);
    вСС = Прав(вТекВремяСтр,2);
    
    вНомНедели = НомерНеделиГода(нДата);

    
    СписЗамен = СоздатьОбъект("СписокЗначений");

    Если Найти(ЗначВозврата,"ГГГГ")>0     Тогда СписЗамен.ДобавитьЗначение("ГГГГ",""+ДатаГод(нДата)); КонецЕсли;
    Если Найти(ЗначВозврата,"ГГ")>0     Тогда СписЗамен.ДобавитьЗначение("ГГ",    Прав(""+ДатаГод(нДата),2)); КонецЕсли;
    Если Найти(ЗначВозврата,"ММММ")>0     Тогда СписЗамен.ДобавитьЗначение("ММММ",тМесяцСтр); КонецЕсли;
    Если Найти(ЗначВозврата,"ММ")>0     Тогда СписЗамен.ДобавитьЗначение("ММ",    Формат(ДатаМесяц(нДата),"Ч(0)2")); КонецЕсли;
    Если Найти(ЗначВозврата,"мМ")>0     Тогда СписЗамен.ДобавитьЗначение("мМ",    ""+ДатаМесяц(нДата)); КонецЕсли;
    Если Найти(ЗначВозврата,"ДД")>0     Тогда СписЗамен.ДобавитьЗначение("ДД",    Формат(ДатаЧисло(нДата),"Ч(0)2")); КонецЕсли;
    Если Найти(ЗначВозврата,"ДД")>0     Тогда СписЗамен.ДобавитьЗначение("ДД",    ""+ДатаЧисло(нДата)); КонецЕсли;
    Если Найти(ЗначВозврата,"НН")>0     Тогда СписЗамен.ДобавитьЗначение("НН",    Формат(НомерНеделиГода(нДата),"Ч(0)2")); КонецЕсли;
    Если Найти(ЗначВозврата,"нН")>0     Тогда СписЗамен.ДобавитьЗначение("нН",    ""+НомерНеделиГода(нДата)); КонецЕсли;
    Если Найти(ЗначВозврата,"КК")>0     Тогда СписЗамен.ДобавитьЗначение("КК",    ""+глНомерКварталаДаты(нДата)); КонецЕсли;
    
    Если Найти(ЗначВозврата,"ЧЧ")>0     Тогда СписЗамен.ДобавитьЗначение("ЧЧ",    вЧЧ); КонецЕсли;
    Если Найти(ЗначВозврата,"WW")>0     Тогда СписЗамен.ДобавитьЗначение("WW",    вММ); КонецЕсли; /// минуты уже есть, чуток меревернем ММ>>WW
    Если Найти(ЗначВозврата,"СС")>0     Тогда СписЗамен.ДобавитьЗначение("СС",    вСС); КонецЕсли;
    Если Найти(ЗначВозврата,"№Нед")>0     Тогда СписЗамен.ДобавитьЗначение("№Нед",    вНомНедели); КонецЕсли;
    
    СЦ = 0;
    Для СЦ = 1 По СписЗамен.РазмерСписка() Цикл
        тПатернЗамн = "";
        тПатернЗнач = СписЗамен.ПолучитьЗначение(СЦ,тПатернЗамн);
        ЗначВозврата = СтрЗаменить(ЗначВозврата,тПатернЗнач,тПатернЗамн);
    КонецЦикла;
    Возврат ЗначВозврата;
КонецФункции // лДатаФормат()

Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 24.2.2020, 20:54