crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> компиляция QT Creator под Windows XP, точка входа в процедуру CancelIoEx не найдена в библиотеке DLL KERNEL3
zazaqwark
  опции профиля:
сообщение 16.2.2017, 17:47
Сообщение #1


Новичок


Группа: Новичок
Сообщений: 3
Регистрация: 18.9.2016
Пользователь №: 4649

Спасибо сказали: 0 раз(а)




Репутация:   0  


На днях обнаружил, что откомпелированное на мной IDE QT Creator не работает под Windows XP, выдает:
точка входа в процедуру CancelIoEx не найдена в библиотеке DLL KERNEL32.

Можно ли как компилить под XP?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Алексей1153
  опции профиля:
сообщение 17.2.2017, 9:11
Сообщение #2


фрилансер
******

Группа: Участник
Сообщений: 2920
Регистрация: 19.6.2010
Из: Обливион
Пользователь №: 1822

Спасибо сказали: 202 раз(а)




Репутация:   35  


zazaqwark, скачай готовый дистрибутив и наслаждайся. Зачем его компилить ?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
zazaqwark
  опции профиля:
сообщение 17.2.2017, 13:45
Сообщение #3


Новичок


Группа: Новичок
Сообщений: 3
Регистрация: 18.9.2016
Пользователь №: 4649

Спасибо сказали: 0 раз(а)




Репутация:   0  


Цитата(Алексей1153 @ 17.2.2017, 9:11) *
zazaqwark, скачай готовый дистрибутив и наслаждайся. Зачем его компилить ?

извините если не понятно написал, но я свою программу скомпилил на Win 7, а потом скопировал на медленный комп с XP, куда невозможно поставить QT в следствии его медленности и малости памяти, дополнил всеми необходимыми дллками, и она не захотела запускаться на XP, выдав вышеуказанную ошибку.
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Litkevich Yuriy
  опции профиля:
сообщение 1.3.2017, 11:59
Сообщение #4


разработчик РЭА
*******

Группа: Сомодератор
Сообщений: 9687
Регистрация: 9.1.2008
Из: Тюмень
Пользователь №: 64

Спасибо сказали: 771 раз(а)




Репутация:   94  


zazaqwark, я компилирую в Вин7, и работает на ВинХП, как с использованием Qt 4.8.x так и c Qt 5.7.x
У меня компилятор GCC 4.8 (Qt 4.8.x) и GCC 5.3 (Qt 5.7.x)
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 23.3.2017, 11:14