crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> QWebSocketServer - не эмитирует сигналы
Алексей1153
  опции профиля:
сообщение 4.12.2018, 14:00
Сообщение #1


фрилансер
******

Группа: Участник
Сообщений: 2846
Регистрация: 19.6.2010
Из: Обливион
Пользователь №: 1822

Спасибо сказали: 211 раз(а)




Репутация:   34  


пытаюсь соорудить http сервер на основе QWebSocketServer и QWebSocket. Делаю по предложенному в справке примеру (ничего там сложного нет, в общем-то)

Просмотрщиком портов вижу, что слушалка поднимается, а когда устанавливаю соединение - established сокет тоже появляется

Но объект QWebSocketServer молчит на предмет сигналов, и даже "асинхронный" вызов hasPendingConnections и nextPendingConnection ничего полезного не возвращает. Что примечательно, сигнал close ловится

Делаю эксперимент: заменяю на том же месте на классы QTcpServer и QTcpSocket (потому что работа аналогичная). И вот все сигналы исправно ловятся.

Что не так с классом QWebSocketServer , какие-то хитрости нужно учесть ?

Или посоветуйте альтернативный вариант http сервера на C++. (можно, конечно, вручную всё пропарсить, но это как-то не очень правильно при наличии специального класса :) )

Сообщение отредактировал Алексей1153 - 4.12.2018, 14:01
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Алексей1153
  опции профиля:
сообщение 4.12.2018, 19:19
Сообщение #2


фрилансер
******

Группа: Участник
Сообщений: 2846
Регистрация: 19.6.2010
Из: Обливион
Пользователь №: 1822

Спасибо сказали: 211 раз(а)




Репутация:   34  


в общем, это нифига не http сервер, а вообще неведома зверушка непонятного назначения. Для подключения в клиенте указывается адрес вида
"ws://host:port"
ни на что больше не реагирует.

А вот нашёл чью-то поделку http://stefanfrings.de/qtwebapp/ , буду пробовать
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Алексей1153
  опции профиля:
сообщение 5.12.2018, 10:02
Сообщение #3


фрилансер
******

Группа: Участник
Сообщений: 2846
Регистрация: 19.6.2010
Из: Обливион
Пользователь №: 1822

Спасибо сказали: 211 раз(а)




Репутация:   34  


чуток пришлось постучать напильником, но вроде рабочая вещь :)
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 10.12.2018, 18:36