crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )

 
Ответить в данную темуНачать новую тему
> Совместимость скомпилированой библиотеки с другой версией Qt
MishaUA
  опции профиля:
сообщение 25.11.2015, 20:07
Сообщение #1


Участник
**

Группа: Участник
Сообщений: 185
Регистрация: 28.4.2013
Пользователь №: 3810

Спасибо сказали: 13 раз(а)




Репутация:   0  


Моя программа поддерживает подключение расширений. Расширение - это библитека которая может быть создана сторонними разработчиками. Я стараюсь всегда качать последнюю версию Qt и собирать программу непосредственно в ней, но сторонние разработчики это делают далеко не всегда. Сейчас каждое расширение содержит функцию, которая возвращает версию Qt, в которой оно было собрано (QT_VERSION), программа в начале запрашивает это значение, и если оно не равно той версии, в которой собрана прога, то расширение не загружается.
Меня интересует, совместимо ли приложение/библиотека, собраные в старой версии, с новыми библиотеками Qt?
Допустим, на компе установлен Qt версии 5.1.1, а расширение собрано в 5.1.0. Не будет ли конфликтов?
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение
Litkevich Yuriy
  опции профиля:
сообщение 27.11.2015, 12:48
Сообщение #2


разработчик РЭА
*******

Группа: Сомодератор
Сообщений: 9656
Регистрация: 9.1.2008
Из: Тюмень
Пользователь №: 64

Спасибо сказали: 807 раз(а)




Репутация:   94  


Описание для Qt4, для Qt5 по идее ничего не должно изменится (подробнее ищи в её документации
Перейти в начало страницы
 
Быстрая цитата+Цитировать сообщение

Быстрый ответОтветить в данную темуНачать новую тему
Теги
Нет тегов для показа


1 чел. читают эту тему (гостей: 1, скрытых пользователей: 0)
Пользователей: 0




RSS Текстовая версия Сейчас: 14.10.2019, 6:48