crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )


  Ответ в Помогите новичку.
Введите ваше имя
Подтвердите код

Введите в поле код из 6 символов, отображенных в виде изображения. Если вы не можете прочитать код с изображения, нажмите на изображение для генерации нового кода.
 

Опции сообщения
 Включить смайлы?
Иконки сообщения
(Опционально)
                                
                                
  [ Без иконки ]
 


Последние 10 сообщений [ в обратном порядке ]
Litkevich Yuriy Дата 25.9.2010, 17:26
 
Цитата(xleksx @ 25.9.2010, 19:32) *
но всё равно интересно что делать чтобы и JPG и др. типы работали =)
я тебе дал ссылку на нашу вики, и написал, что там нужно прочитать
xleksx Дата 25.9.2010, 15:32
  хех, и правда поставил .png и всё норм стало, но всё равно интересно что делать чтобы и JPG и др. типы работали =)

СПС! =)
Litkevich Yuriy Дата 25.9.2010, 15:08
  дык у тебя jpeg, отсюда и проблемы. png должно читать всяко.

Смотри в нашей вики Qt -> FAQ -> о развёртывании приложений, хотя это всё из асистента.
xleksx Дата 25.9.2010, 13:45
 
Цитата(kwisp @ 25.9.2010, 17:23) *
это скорее всего кодеки картинок не видит твоя прога если запускаешь не в Creatore.
здесь на вики есть информация как исправить положение.

Скажи хоть где примерно искать =)
kwisp Дата 25.9.2010, 13:23
 
Цитата(xleksx @ 25.9.2010, 13:29) *
И кстати даже при задании полного пути к файлу прога "видит" файл только когда запускается из под Qt Creator (релиз/отладка), а когда запуская экзешник - ничего нету...

это скорее всего кодеки картинок не видит твоя прога если запускаешь не в Creatore.
здесь на вики есть информация как исправить положение.
xleksx Дата 25.9.2010, 12:29
 
#include <QtGui>

// ----------------------------------------------------------------------
int main(int argc, char** argv)
{
    QApplication app(argc, argv);
    QWidget      wgt;

    QWidget* pwgt1 = new QWidget(&wgt);
    QPalette pal1;
    pal1.setColor(pwgt1->backgroundRole(), Qt::blue);
    pwgt1->setPalette(pal1);
    pwgt1->resize(100, 100);
    pwgt1->move(25, 25);
    pwgt1->setAutoFillBackground(true);

    QWidget* pwgt2 = new QWidget(&wgt);
    QPalette pal2;
    pal2.setBrush(pwgt2->backgroundRole(), QBrush(QPixmap("D://stone.jpg")));
    pwgt2->setPalette(pal2);
    pwgt2->resize(100, 100);
    pwgt2->move(75, 75);
    pwgt2->setAutoFillBackground(true);

    wgt.resize(200, 200);
    wgt.show();

    return app.exec();
}

И кстати даже при задании полного пути к файлу прога "видит" файл только когда запускается из под Qt Creator (релиз/отладка), а когда запуская экзешник - ничего нету...

и ещё даже когда использую .qrc то при запуске exe'шника картинки всё равно нету...
Litkevich Yuriy Дата 25.9.2010, 12:15
 
Цитата(xleksx @ 25.9.2010, 1:14) *
в С++ вроде просто помещаешь картинку рядом с exe'шником и всё нормально,
С++ - язык программирования, он вообще картинки не загружает.

Покажи как ты загружаешь картинку
xleksx Дата 25.9.2010, 12:13
  Спасибо за совет, но..
1. не помогло
2. ты не совсем понял проблему =)
Я думаю тут проблема развёртывания приложения, т.к. тот же код в Ubuntu компилится и всё отлично работает... А в винде не очень всё понятно =(
Алексей1153 Дата 24.9.2010, 21:37
  на первый взгляд, ты не задал путь относительно расположения экзешника. А у дебажного и релизного экзешников расположение в общем случае разное - в общем, нужно приглядеться помнимательнее и всё . Для удобства работы можно задать разные пути для дебага и релиза

например,
#ifdef QT_NO_DEBUG
  //релиз
#define def_path__ "./"            "file.png"
#else
  //дебаг
#define def_path__ "../res/"            "file.png"
#endif


для релиза будет искаться рядом с экзешником
для дебага - шаг на директорию вверх, а там в папке res
xleksx Дата 24.9.2010, 21:14
  Всем привет, только начал Qt учить, заранее извиняюсь за глупый вопрос...
Проблема такая:
Пишу прогу, которая подгружает картинку и показывает её с помощью QLabel, ну или просто заливаю виджет картинкой...
Помещаю картинку в папку теневой сборки (desktop) компилю и запуская из под Qt Creator'а всё нормально, картинку видно.
Но вот когда запускаю exe'шник (Релиз) картинки как-будто нету (картунку ложу рядом с exe'шником)... Если писать полный путь ("C://...") то всё нормально... в С++ вроде просто помещаешь картинку рядом с exe'шником и всё нормально, а тут не получается, помогите кто может =)
Просмотр темы полностью (откроется в новом окне)
RSS Текстовая версия Сейчас: 23.10.2019, 12:52