crossplatform.ru

Здравствуйте, гость ( Вход | Регистрация )


  Ответ в QTCreator и Open CV(не линкуется)
Введите ваше имя
Подтвердите код

Введите в поле код из 6 символов, отображенных в виде изображения. Если вы не можете прочитать код с изображения, нажмите на изображение для генерации нового кода.
 

Опции сообщения
 Включить смайлы?
Иконки сообщения
(Опционально)
                                
                                
  [ Без иконки ]
 


Последние 10 сообщений [ в обратном порядке ]
RazrFalcon Дата 28.5.2010, 15:54
 
Цитата(Litkevich Yuriy @ 22.5.2010, 5:04) *
и такое бывает.
А за то, что написал решение, спасибо тебе

Та не за что, как говорится "Спрашивай и обретёшь знания, не спрашивай и научишься думать."
Litkevich Yuriy Дата 22.5.2010, 5:04
 
Цитата(Гость_RazrFalcon_* @ 22.5.2010, 1:38) *
Спасибо за то что никто не ответил.
и такое бывает.
А за то, что написал решение, спасибо тебе
RazrFalcon Дата 21.5.2010, 21:38
  Спасибо за то что никто не ответил.
Вот и ответ:
LIBS += "C:\OpenCV2.1\lib\cv210.lib" \
"C:\OpenCV2.1\lib\highgui210.lib" \
"C:\OpenCV2.1\lib\cxcore210.lib"
грубо говоря пути. Обязательно без пробелов. 210 - это версия моя 2.1

Ну и
#include "cv.h"
#include "highgui.h"
ГостьN3 Дата 19.5.2010, 20:06
  +1
Гость Дата 18.5.2010, 13:14
  Та же проблема может кто ни будь ответит, уже второй день
undefined reference to `cvCreateCameraCapture'
undefined reference to `cvGrabFrame'
...
ну и в таком духе
Евгения Дата 29.4.2010, 18:47
 
Цитата(Litkevich Yuriy @ 28.4.2010, 18:29) *
Во-первых, оформляй сообщения так, чтобы их было удобно читать, смотри тему Справка по кнопкам и тэгам форума
во-вторых, что это за сообщение такое часть на русском языке, часть на английском?

Дико извиняюсь за формат сообщения. :( Тачпад глюкнул..Пока я приводила сообщение в божеский вид, он очередной раз неверно истолковал мои движения и видимо послал сообщение на отправку..а так как я гость, редактировать его мне не дали.. Мне правда стыдно..
molchanoviv Дата 28.4.2010, 21:53
  Поправил.
Litkevich Yuriy Дата 28.4.2010, 18:29
  Во-первых, оформляй сообщения так, чтобы их было удобно читать, смотри тему Справка по кнопкам и тэгам форума
во-вторых, что это за сообщение такое часть на русском языке, часть на английском?
Евгения Дата 28.4.2010, 17:46
  Доброго времени суток!

Мне понадобилась библиотека OpenCV, но никак не могу ее приладить к QTCreator
Вот моя тестилка:
main.cpp:
#include <QtCore/QCoreApplication>
#include <cv.h>
#include<highgui.h>
#include <cxcore.hpp>

using namespace cv;

int _tmain(int argc, _TCHAR* argv[])

{
cv::Mat M(7,7,CV_32FC2,Scalar(1,3));

return 0;

}


файл .pro:

Цитата
QT -= gui

TARGET = testopencv CONFIG += console CONFIG -= app_bundle INCLUDEPATH += C:/OpenCV2_1/include/opencv TEMPLATE = app

LIBS += C:/OpenCV2_1/lib/cxcore210d.lib \ C:/OpenCV2_1/lib/cv210d.lib \ C:/OpenCV2_1/lib/highgui210d.lib\ C:/OpenCV2_1/lib/cvaux210d.lib SOURCES += main.cpp

Я попыталась использовать -L и -l like LIBS+= -LC:/OpenCV2_1/lib -lcxcored

и файл .pri
Цитата
QMAKE_LIBDIR += C:/OpenCV2_1/lib/Debug

LIBS += -lcxcore210d \ -lcv210d \ -lhighgui210d

Текст ошибки:
Цитата
debug/main.o:C:\griskin\test\app\testopencv/../../../../OpenCV2_1/include/opencv/cxcore.hpp:97: undefined reference to cv::format(char const*, ...)'

Кто-нибудь может мне помочь? Спасибо!

В Visual Studio работает, но мне нужно чтобы работало в QTCreator.
Просмотр темы полностью (откроется в новом окне)
RSS Текстовая версия Сейчас: 9.12.2022, 15:15